All security reports
NVD security advisory

Security advisory for Consul-k8s versions 0.42.0 and later

CVE-2026-110720

Full advisory details, affected packages, severity context, and original source.

Affected technology

Consul-k8s versions 0.42.0 and laterKubernetes ecosystem

Advisory overview

Consul-k8s versions 0.42.0 and later are vulnerable to a cross-namespace authorization bypass in component ACL binding rules that may allow an attacker to obtain elevated Consul privileges. This vulnerability (CVE-2026-110720) is fixed in consul-k8s 2.1.0 and 1.8.18.

Related references

Your vulnerabilities. One clear dashboard.

Find and review known vulnerabilities across your applications and infrastructure in one dashboard, so your team can see what needs attention and take action to fix it.

Create your account
Consul-k8s versions 0.42.0 and later are vulnerable to a cross-namespace authorization bypass in component ACL | Security report | Cevnitra